haios/modules/flake/fmt.nix
2025-02-17 16:48:14 +02:00

25 lines
435 B
Nix

{inputs, ...}: {
imports = [inputs.treefmt-nix.flakeModule];
perSystem = {
pkgs,
config,
...
}: {
formatter = config.treefmt.build.wrapper;
treefmt = {
flakeCheck = true;
projectRootFile = "flake.nix";
programs = {
nixfmt = {
enable = true;
package = pkgs.alejandra;
};
statix.enable = true;
shfmt.enable = true;
};
};
};
}