mafs-thingy/rust/shell.nix
2025-01-23 23:12:18 +02:00

21 lines
275 B
Nix

{
stdenv,
mkShell,
# extra tooling
clippy,
rustfmt,
rust-analyzer,
inputs, # our inputs
self ? inputs.self,
}:
mkShell {
inputsFrom = [ self.packages.${stdenv.hostPlatform.system}.default ];
packages = [
clippy
rustfmt
rust-analyzer
];
}