mirror of
https://github.com/blahai/nyx.git
synced 2025-01-18 19:10:21 +00:00
46 lines
1.1 KiB
Nix
46 lines
1.1 KiB
Nix
{
|
|
config,
|
|
lib,
|
|
pkgs,
|
|
...
|
|
}: {
|
|
services = {
|
|
pipewire = {
|
|
enable = true;
|
|
alsa.enable = true;
|
|
alsa.support32Bit = true;
|
|
pulse.enable = true;
|
|
jack.enable = true;
|
|
|
|
extraConfig = {
|
|
pipewire."92-low-latency" = {
|
|
"context.properties" = {
|
|
"default.clock.rate" = 48000;
|
|
"default.clock.quantum" = 32;
|
|
"default.clock.min-quantum" = 32;
|
|
"default.clock.max-quantum" = 64;
|
|
};
|
|
};
|
|
pipewire-pulse."92-low-latency" = {
|
|
"context.properties" = [
|
|
{
|
|
name = "libpipewire-module-protocol-pulse";
|
|
args = {};
|
|
}
|
|
];
|
|
"pulse.properties" = {
|
|
"pulse.min.req" = "32/48000";
|
|
"pulse.default.req" = "32/48000";
|
|
"pulse.max.req" = "32/48000";
|
|
"pulse.min.quantum" = "32/48000";
|
|
"pulse.max.quantum" = "32/48000";
|
|
};
|
|
"stream.properties" = {
|
|
"node.latency" = "32/48000";
|
|
"resample.quality" = 1;
|
|
};
|
|
};
|
|
};
|
|
};
|
|
};
|
|
}
|