mirror of
https://github.com/blahai/nyx.git
synced 2025-01-18 11:00:20 +00:00
67 lines
1.6 KiB
Nix
67 lines
1.6 KiB
Nix
{
|
|
description = "Elissa's funny little flake";
|
|
|
|
outputs = inputs: inputs.flake-parts.lib.mkFlake {inherit inputs;} {imports = [./modules/flake];};
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:nixos/nixpkgs?ref=nixos-unstable";
|
|
nixpkgs-smol.url = "github:nixos/nixpkgs?ref=nixos-unstable-small";
|
|
chaotic.url = "github:chaotic-cx/nyx/nyxpkgs-unstable";
|
|
nur.url = "github:nix-community/NUR";
|
|
wezterm.url = "github:wez/wezterm?dir=nix";
|
|
catppuccin.url = "github:catppuccin/nix";
|
|
hyprland.url = "github:hyprwm/Hyprland";
|
|
|
|
haivim = {
|
|
url = "github:blahai/haivim";
|
|
inputs = {nixpkgs.follows = "nixpkgs";};
|
|
};
|
|
|
|
ags = {
|
|
url = "github:Aylur/ags/v1";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
|
|
spicetify-nix = {
|
|
url = "github:Gerg-L/spicetify-nix";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
|
|
disko = {
|
|
url = "github:nix-community/disko/master";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
|
|
agenix = {
|
|
url = "github:ryantm/agenix";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
|
|
sops-nix = {
|
|
url = "github:Mic92/sops-nix";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
|
|
systems = {
|
|
url = "github:nix-systems/default";
|
|
};
|
|
|
|
flake-parts = {
|
|
url = "github:hercules-ci/flake-parts";
|
|
inputs.nixpkgs-lib.follows = "nixpkgs";
|
|
};
|
|
|
|
flake-utils = {
|
|
url = "github:numtide/flake-utils";
|
|
};
|
|
|
|
easy-hosts = {
|
|
url = "github:isabelroses/easy-hosts";
|
|
};
|
|
|
|
home-manager = {
|
|
url = "github:nix-community/home-manager";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
};
|
|
}
|