nyx/modules/nixos/hardware/gpu/default.nix
2025-01-12 19:18:13 +02:00

20 lines
316 B
Nix

{lib, ...}: let
inherit (lib) mkOption types;
in {
imports = [
./amd.nix
./novideo.nix
];
options.olympus.device.gpu = mkOption {
type = types.nullOr (
types.enum [
"amd"
"nvidia"
"hybrid-nv"
]
);
default = null;
description = "GPU brand";
};
}